Spedemix

ML 200 build doesn't turn when enemy player Sparks it

Recommended Posts

Error report
Describe problem and what you saw ML 200 Mechanical Leg build doesn't turn when enemy player sparks it.
What you expected to see I expect an ML 200 build to be able to turn (albeit at 50% speed) when the build gets sparked. Spark is suppose to slow down victims, not render them immobile.
Conditions in which error reproduce Have Leg build. Have an enemy Spark it. Have a bit of luck too since it doesn't always happen (I think).
Problem details

This has happened few times now. The broken physics of legs makes this hard to track because sometimes legs become immobile when an enemy simply pins them against a wall etc. I've had situations where an enemy pins me to a wall while sparking me and during those moments I'm not not sure which one is rendering me unable to turn: the pinning or Sparking.

This bug started to occur somewhere between 0.9.60 and 0.9.70. There was some kind of undocumented change to legs which slowed the inertia down a bit from what they were right after the buff introduced in 0.9.60.

The "not being able to turn" strongly resembles another bug which was opened very recently. https://forum.crossout.net/index.php?/topic/288184-ml-200-won%C2%B4t-turn/ Here the culprit seems to be serious overtonnage.

In the log the battle where this bug occurs is the last battle played starting at 20:44:45.517

In the video you can see how I'm actually turning and the turning stops when the Sparking begins. Throught the sparking I'm holding down Q, W and A in an attempt to move diagonally and turn left. Here I'm trying to shoot the hover cricket again. Diagonal movement works, turning doesn't. As you can see it doesn't matter what the Spark is attacking (leg or gun of plow) the build doesn't turn.

Frequency of reproduction sometimes
Time of bug  

 

Video of the bug:

 

 

 

 

 

2018.05.23 07.23.02.zip

5c05367a.design

  • Upvote 3

Share this post


Link to post
Share on other sites

I was wondering what was going on. Had my legs lock up like that quite a few times.

Share this post


Link to post
Share on other sites

I run spark daily, I have noticed similar occasionally. 

If I notice any other details I'll add them here

Bedlam prolly the best place to test in isolation from other drama (AU/as server has low population in bedlem, great for tests

Share this post


Link to post
Share on other sites

Mom! It happened again!

 

 

Same problem, different build. My vehice can't steer at 0.11sec. I regain my steering by stopping the diagonal movement. After that I can steer just fine even when the enemy is Sparking me.

 

Log: 2018.05.24 19.02.47.zip The battle shown in the video starts at 23:04:17.508 and I kill this enemy at 23:05:35.858

 

Vehicle design: 33bb1901.design

 

Edited by Spedemix
added vehicle design

Share this post


Link to post
Share on other sites

Yeah, this is actually more common than I realized.

 

 

Log:2018.05.26 19.13.06.zip  It's the last battle in log starting at 23:21:36.435

 

Design: b9bb78ac.design

 

Is posting more of these logs useful or does it clutter the tread?

Share this post


Link to post
Share on other sites

@Spedemix At us the problem does not repeat.

Most likely the problem is in the keyboard, depending on the keyboard model there may be a restriction on the simultaneous pressing of the key.

More details can be read, for example, here: https://en.wikipedia.org/wiki/Rollover_(key)

You can search for various tests (Keyboard Ghosting Test or key roller test), but I can not guarantee 100% accuracy of such tests.
 

  • Upvote 2

Share this post


Link to post
Share on other sites

I've used legs for a while and I have been sparked a bit but I've never encountered this bug. I'm using the Logitech G910 orion spark keyboard built for gaming that may be why I never encountered this. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Hmm, I see.

 

My cheap keyboard does indeed have some rollover issues. For example if I hold QWA, the H button doesn't register . Some of the online rollover tests replicate this correctly (=won't show the H button in the list).

However in the first video I'm only pressing QWA and am actually holding them down way before getting sparked. The A button just stops working on it's own without me pressing anything else. So far I haven't experienced these kind of issues anywhere else except with the Spark in XO. But I'll do some more tests to see if it's really my keyboard (that's still totally possible).

 

If you can't replicate it on your end, I guess there's nothing we can do about it for now.

Share this post


Link to post
Share on other sites

This bug still occurs on Xbox.

I lose the ability to turn when sparked and just run straight forward.

Share this post


Link to post
Share on other sites

I have to say I suffer from this too, And after some testing I'm pretty sure it's not the aforementioned roll-over problem.

 

I'll try to provide a video with an on-screen keyboard.

Share this post


Link to post
Share on other sites

Well, here it is:

 

 

This is an edited video (cut away the extra fluff) showcasing how pressing A or D won't turn the build when it's being Sparked. You can also see how the build turns abruptly once the Sparking stops.

 

The surest way to reproduce this is to move diagonally and attempt to turn once being sparked. I'm not 100% sure but I think you also need to have reached almost max speed of legs too; in the short test we did I could never get legs lock up if moving slowly.

 

It's not a rollover issue if the keyboard app registers my key presses.

 

Log of the session: 2018.06.26 21.01.42.zip  at 06:46:14.499 I ask the help of the dude who's doing the sparking. The video begins few seconds after that.

 

Vehicle design: 86ad815b.design

 

Share this post


Link to post
Share on other sites

Dying because of a bug gets old really fast:

 

 

Here's the log for good measure: 2018.07.04 03.49.21.zip 

The last battle in the log is the one shown in video.

 

If there's anything else I can do speed this up I'm more than happy to help.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yeah unfortunately I'm in a position where I simply have to disconnect from a match if somebody sparks me and I don't happen to have machine guns.

 

 

This is severely degrading my play experience and all of the other players who play with ML 200 (which are getting more and more common).

Share this post


Link to post
Share on other sites

this happened to me today i was wondering whats going on when i got hit by spark, my spider suddenly refused to move, i cant do anything and let enemy just kill me, please fix that ****.

Edited by swaggot96

Share this post


Link to post
Share on other sites

1) Why would that happen only when you are being hit by spark?

2) Did some test and i had no "ghost key" when pressing the combination of keys used in game

3) Someone wrote that it's also occuring on xbox

 

  • Upvote 1

Share this post


Link to post
Share on other sites
12 hours ago, _Furet_ said:

1) Why would that happen only when you are being hit by spark?

Not only. We met similar issues at other situations.

12 hours ago, _Furet_ said:

2) Did some test and i had no "ghost key" when pressing the combination of keys used in game

It depends from keyboard

12 hours ago, _Furet_ said:

3) Someone wrote that it's also occuring on xbox

XBOX OS and Windows produced by Microsoft...

Share this post


Link to post
Share on other sites

Here's an update on the bug.

 

Video showcasing the bug still ocurs but much more rarely. This is an unedited video where we're trying all the different ways the legs might get locked up. You'll also hear my lovely voice in it! :)

 

 

Synopsis is: The bug happens much less now it seems. The only way I could reproduce it is by moving diagonally, getting sparked and then attempting to turn. Moving in a single direction doesn't seem to activate it anymore. You can also see in the video that whenever the bug occurs (=my craft cannot turn), it will actually slow down even futher whever you attempt to turn.

 

Let's get one thing straight: IT IS NOT A KEYBOARD ISSUE. Stop talking about the keyboard issue OK? I have ruled it out already. In above video I demonstrate one rollover problem my keyboard has.

 

If I press press a certain keyboard combination and my Spider craft moves in a certain way, then I get Sparked and my Spider then moves diferently despite presing the same buttons, it is not a keyboard issue.

 

Here's log: 2018.09.06 05.39.18.zip   The bedlam session show in the video starts at 13:12:29.054 according to the combat.log

 

Here's the design of my Spider Craft used in the vid: 43f876bc.design

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I think comrade Skula is trolling us

20 hours ago, Skula1975 said:

Not only. We met similar issues at other situations.

Maybe but i doubt it's the case of the players in this thread, at least for me it only happens when i'm being hit by spark. I've never had any issue with legs in other circumstances

20 hours ago, Skula1975 said:

It depends from keyboard

1vs1 my keyboard vs yours! Seriously i don't think it's related to keyboard

20 hours ago, Skula1975 said:

XBOX OS and Windows produced by Microsoft...

I took this example having in mind xbox users playing with controllers (for tiny hands) and not keyboard

  • Thanks 1

Share this post


Link to post
Share on other sites
15 hours ago, Spedemix said:

Video showcasing the bug still ocurs but much more rarely

Good video. Will be think what happend. 

0098035

  • Thanks 1

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.