Carnaxus

Game opens partially offscreen on first launch

Recommended Posts

Error report
Describe problem and what you saw I play Crossout at 2560x1440 resolution on a 27" screen, with a 19" screen to the right at 1440x900. I use Windowed Borderless mode. Approximately 50% of the time, the game opens up centered on the "middle point" if you were to treat both screens as one instead of centered on my main screen. Switching to fullscreen and back positions it correctly, and it doesn't change until next time I run the game...sometimes. Other than that, the game runs flawlessly.
What you expected to see The game properly centered upon launch, without me having to do anything.
Conditions in which error reproduce Appears to only happen the first time I launch the game after my computer's been asleep and wakes up.
Problem details Already described in full detail above.
Frequency of reproduction Frequent
Time of bug  

 

Apparently this has been going on for quite a while: 

 

 

 

BORKED.jpg

Crossout logs.zip

Edited by Carnaxus

Share this post


Link to post
Share on other sites
21 hours ago, KrissGO said:

Use Alt+Tab and switch to the game window 

That only works if I'm already using plain fullscreen mode.  I'm using windowed fullscreen mode.  Alt-tabbing does not minimize the game nor does it fix this issue.

Edited by Carnaxus

Share this post


Link to post
Share on other sites
3 hours ago, Carnaxus said:

That only works if I'm already using plain fullscreen mode.  I'm using windowed fullscreen mode.  Alt-tabbing does not minimize the game nor does it fix this issue.

Then you'll have to go to settings and switch to fullscreen (and back to windowed fullscreen if you want so) each time the game is offset.

It resets the window to it's normal position.

Share this post


Link to post
Share on other sites

...Yes, that's exactly what I do, every time.  Did you even fully read the first post or did you just start replying to the title?

Share this post


Link to post
Share on other sites

Oddly enough it hasn't happened at all over the past two days.  I'll keep an eye out and see if there's some factor I can see that affects it.  Please don't lock this for...ionno, a week maybe?

Share this post


Link to post
Share on other sites
12 hours ago, Carnaxus said:

Please don't lock this for...ionno, a week maybe?

Ok

Share this post


Link to post
Share on other sites

settings: windowd fullscreen

this happens to me to, "game not respoding" then a second or two later game resumes and stays like that.

its not videodrivers, this has to be something else

 

not a huge isse when one can go in settings, set to fullscreen, aply, and set it back to windowed fullscreen

  • Upvote 1

Share this post


Link to post
Share on other sites

Just did a quick test of something I kinda half-noticed, and sure enough...after waking the computer up from sleep mode, if I run any other fullscreen application before launching Crossout, Crossout doesn't load offscreen.  It's like Crossout can't figure out where the screen edges are until something else leaves a marker.

Share this post


Link to post
Share on other sites
5 hours ago, Carnaxus said:

Just did a quick test of something I kinda half-noticed, and sure enough...after waking the computer up from sleep mode, if I run any other fullscreen application before launching Crossout, Crossout doesn't load offscreen.  It's like Crossout can't figure out where the screen edges are until something else leaves a marker.

As I understand, if PC wake up after sleep mode and run Crossout immediately, bug will be repeated?

Share this post


Link to post
Share on other sites

Let me test that real quick, I just woke up my computer.  I'll edit this post rather than double post.

 

Edit: Annoyingly, apparently that is not related.  Argh.  Back to searching for our needle in the haystack, I guess.

Edited by Carnaxus
Blargh.

Share this post


Link to post
Share on other sites
8 hours ago, Carnaxus said:

It seems I'm not alone.

Yes, but we can't reproduce it and, therefore, can't fix.

Share this post


Link to post
Share on other sites

Hmm.  This is a bit far-fetched, but if we could get everyone from those threads who said they have the same issue to send in their computer specs, maybe there's a common theme?  Mine are in the DxDiag file I attached, of course.

 

Edit:  Wait a minute!  I think I may actually have been right before when I said that having something else fullscreen first makes Crossout start in the right spot.  I initially said that had no effect because I wasn't counting a fullscreen Youtube video as "a fullscreen program," but I did have a video fullscreened then and I don't now...and it loaded offscreen this time and correctly that time.  It could also have something to do with having different resolutions for each of my two screens rather than two identical screens?  My main screen is 27", 2560x1440; my secondary screen is 19", 1440x900 (not even full 1080p ><).  Is that something you guys can test?

Also, here's a link to the full component list for my current computer, just in case the DxDiag file missed something.

Edited by Carnaxus
IDEA!

Share this post


Link to post
Share on other sites
8 hours ago, Carnaxus said:

Is that something you guys can test?

Please, write step-by-step instruction

Share this post


Link to post
Share on other sites

I feel like I'm grasping at straws.  In the dark.  Without a flashlight.

I thought maybe that was it, but just now I woke my computer from sleep mode and went straight to Crossout and...it loaded correctly.  I'm completely out of ideas.

Edited by Carnaxus

Share this post


Link to post
Share on other sites

to fix the screen offset just go to your documents/my games/ crossout and open window.xml with a notepad or preferrably notepad ++  and change this line marked in red into zeros, just leave ur resolution width and height untouched coz urs might be different than my screen.
<ClientRect X="58" Y="75" Width="1024" Height="720" /> to <ClientRect X="0" Y="0" Width="1024" Height="720" />  then save it and make the file read only. and reopen the game

Edited by shinvonhaidma
added more details
  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

That appears to have fixed it, although I haven't tested straight from sleep mode yet.

 

Edit: First time waking from sleep and launching the game, seems to have worked so far.

Edited by Carnaxus

Share this post


Link to post
Share on other sites

Wellp, that little edit seems to have fixed the issue.

It might be possible to trace what bit of code is incorrectly modifying that file though.  I can't do it, but you devs probably can.

Share this post


Link to post
Share on other sites
On 6/30/2019 at 9:39 PM, shinvonhaidma said:

to fix the screen offset just go to your documents/my games/ crossout and open window.xml with a notepad or preferrably notepad ++  and change this line marked in red into zeros
<ClientRect X="58" Y="75" Width="1024" Height="720" /> to <ClientRect X="0" Y="0" Width="1024" Height="720" />  then save it and make the file read only. and reopen the game

Thank you.  This is a simple change of game setting I guess.  I am not a programmer.

What puzzle me is this bug have been pointed out by so many users for so long, yet, it went away and came back.  Why can't it be program in on a patch? To fix this issue?

Share this post


Link to post
Share on other sites

i m glad it helped :D i know it wud be easy to implemented to the client launcher itself but i guess the devs simply overlooked it due the fact they wont be supporting the older dx soon. basically no potatos eventually. :S

Share this post


Link to post
Share on other sites

Using Repair on the launcher fixed this for me. I for some reason do not have any config file visible in the shown directory, even turning on show hidden files doesn't show.
Very glad install repair worked though.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.