Recommended Posts

Hello.

This is my first post on the forum. I Play on ps4.

Been playing XO most days for about 3/4 months. 

I read the forum regularly, just to stay up to date on news really. 

Something ive noticed in game, that drives me absolutely mad, is this random drop in speed and acceleration of my car. 

My build relies on ambush tactics. Speed and movement is everything. I single out certain builds & weaknesses in the opposing team. (Melee. Spider and drone builds) and move on to the next. (keeping an eye out that one build that wrecks me every time) lol

Obviously this random drop speed and power isn't welcome. Infact it actually turns me into a bit of a liability.

This drop doesn't just happen after updates. It's happened three times since the last one. Today i was on for maybe 2 hours. It got so bad i couldn't be bothered to play anymore. I played maybe 15 games. Top 3 most games 8 MVPs. So it wasn't like it dramatically effected my resource gain or kills. But it felt like total s*** I had to switch it off. 

Not too fussed about losing. (As long as I play well) high risk / reward play style suits me fine. But taking 14 seconds to get from 0 to 90kph (I ride a bicycle at about 30) is an awful experience. Especially when you're being shot at.

(Usually takes about half that) 

So whats going on? Are you penalising me for using wheels or just trying to slow me down and get me shot?

Love the game.

Just today, the enjoyment came - by switching it off. 

Peace. 

Share this post


Link to post
Share on other sites

You sound a lot like me... 

We've had issues in the past regarding speed and acceleration of vehicles, especially wheels and also related to turning while accelerating.. has there been anything consistent to link the times this has happened? I'm on xbox but console platforms seem to just inherit the sh*t that PC throws out..

If not, it could just be some lag of some sort, even with a good connection it may be rubber banding you in some weird way, not entirely sure

  • Thanks 1

Share this post


Link to post
Share on other sites

Sounds like tonnage or wheel placement issues which can slow you while turning, Porc spam also lags the game. Make sure nothing can scrape the ground. Also make sure your upload speed is solid, from my experience Crossout requires more than other games. Plus is someone shoots a wheel off or your engine, that would put you over tonnage and slow you down too.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for the reply chaps. 

Just to clarify, I use 4 Monster wheels. 

Mass & tonage all ok. (within / under limits) 

Max speeds 107.

Acceleration / power bar at about 80%

 

Share this post


Link to post
Share on other sites
6 minutes ago, Moregas said:

Just to clarify, I use 4 Monster wheels. 

Bigfoot?  Just to Clarify.  (I've had similar movement problems on PC, like the auto-reverse glitch, but it doesn't seem to change with which wheels.  Consoles may be different.)

  • Thanks 1

Share this post


Link to post
Share on other sites

In case you use "relative to car" controls (i.e. throttle on left stick), make sure your pad is fine. 

Mine is somewhat broken, when i give full throttle sometimes the input flickers between full throttle and zero throttle (which is visible on hovers but not on wheels).

  • Thanks 1

Share this post


Link to post
Share on other sites

Hoping thats case. 

Was just curious, whether anyone else experiences this. Wondered, if they do this intentionally, 

For whatever reason,

Maybe slowing the game play down, reduces the drain on the system or servers Idk. 

But it was like swapping a race car for a shopping trolley. 

Share this post


Link to post
Share on other sites

There is one common drawback everyone have felt on occations: wrong co-driver. There are a couple of tonnage/mass and weight reduction perks there that can affect your vehicle. I use wheels more or less on a daily basis, but have not noticed anything odd lately.

  • Thanks 1

Share this post


Link to post
Share on other sites

In low powerscore, when you are running 4-6 wheels on the white and blue cabs  changing or adding a wheel can change everything. Them little cabs aint got a lot of power, goi g from medium wheels to racing for example trashes the acceleration

 

Edited by Babylonsburning
  • Thanks 1

Share this post


Link to post
Share on other sites
On 11/28/2019 at 11:17 AM, xXMrSkeletonXx said:

Sounds like tonnage or wheel placement issues which can slow you while turning, Porc spam also lags the game. Make sure nothing can scrape the ground. Also make sure your upload speed is solid, from my experience Crossout requires more than other games. Plus is someone shoots a wheel off or your engine, that would put you over tonnage and slow you down too.

All my wheeled builds accelerate when turning.  Like a spike in speed as I turn by seven km or so.  I usually push tonnage to one point under if possible

Share this post


Link to post
Share on other sites
2 minutes ago, tenshiijin said:

All my wheeled builds accelerate when turning.  Like a spike in speed as I turn by seven km or so.  I usually push tonnage to one point under if possible

Rip losing your engine 

Share this post


Link to post
Share on other sites
47 minutes ago, Xbox_M_420 said:

Rip losing your engine 

Almost never happens on my current builds.  I loose enough weight before the engine gets taken.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.