Knutowskie

Game always starts in a decentral position

Recommended Posts

 
Error report
Describe problem and what you saw When i start the game via the launcher, it opens up on a position somewhere right and down, centered out of the monitor. This is every 1st launch of the game. On the second launch it works as expected.
What you expected to see Game launches on the first try centered on the main screen.
Conditions in which error reproduce After booting the PC, opening the launcher on primary monitor, start the game = faulty behaviour
Problem details i have 3 screens. different size. it alyways happens on my machine and a friend of mine told me, he got the same error with his setup. he got 2 screens.
Frequency of reproduction always
Time of bug 16:29

logs.zip DxDiag.zip .launcher_log.zip

  • Upvote 1

Share this post


Link to post
Share on other sites

It's a known bug, but we can't reproduce it.

Try to delete windows.xml file in Documents/My Game/Crossout/ folder.

Share this post


Link to post
Share on other sites

this worked one time for me. will see if this is a real fix. i compared the old xml with the new one. same content:

Spoiler

<?xml version="1.0"?>
<Windows>
  <MainWindow WindowMode="BorderlessFullscreen">
    <PreFullscreen IsMaximized="false">
      <ClientRect X="190" Y="213" Width="1904" Height="990" />
    </PreFullscreen>
  </MainWindow>
</Windows>


 

My resolution is 2560x1440.

Is the X and Y a relative or absolute attribute?

My guess:

width and height set to display resolution, X and Y to the half of it?

Share this post


Link to post
Share on other sites
1 hour ago, Knutowskie said:

Is the X and Y a relative or absolute attribute?

It's a absolute workplace coordinates of left-up corner of screen

1 hour ago, Knutowskie said:

width and height set to display resolution, X and Y to the half of it?

It's a game screen size. If BorderlessFullscreen enabled then it's previous screen size

Share this post


Link to post
Share on other sites

happens now and then for me to, instead of relaunching the game you can go in video options, set to fullscreen, aply and set to borderless window again and apply.

 

If this is some info that can be of use for gajin...

Allso the game forces itself ontop off all other programs, wanting priority over everything else, so cant alt tab untill Im ingame.

Its even so bad I cant get taskmannager up.

Even some overlay apps/programs like Chrome "Picture-in-Picture Extension" for watching youtube videos while playing crossout doesnt work with crossout, same applies for Opera GX youtube version.

Share this post


Link to post
Share on other sites

i guess i found a solid workaround:

<?xml version="1.0"?>
<Windows>
  <MainWindow WindowMode="Fullscreen">
    <PreFullscreen IsMaximized="false">
      <ClientRect X="0" Y="0" Width="2560" Height="1440" />
    </PreFullscreen>
    <DeviceMode Width="2560" Height="1440" RefreshRateNumerator="0" RefreshRateDenominator="0" />
  </MainWindow>
</Windows>

width and height set to exact screen and game resolution. X and Y set to 0.

then i set the file to read-only. now it works every time for me. the game itself tries to mess it up every time and now can't.

Edited by Knutowskie

Share this post


Link to post
Share on other sites
8 minutes ago, doithuong said:

Me too, I do not know how to fix it

Read this topic from begin. 

Ask here if there are any unclear things

Share this post


Link to post
Share on other sites

An easy workaround when it happens is to go to options, switch to another display mode and back. Have to do it every time it happens, though. Takes about 5 seconds.

Share this post


Link to post
Share on other sites

Hello @ all,

i am able to reproduce this behavior under the following circumstances:

1. when you are using more then 1 Display (yes it happens sometimes, when Windows looses the saved position of the last state)
2. when you change the focus of your mouse during gamestart (the Windows window management switches to scaled windows)

How to Fix:
You can't fix it at this time, just because it is a standard Windows OS behavior. But you can try not to click anywhere else during gamestart (just to prevent loosing or changing the focus).

Workaround:

On 3/16/2020 at 12:56 AM, Knutowskie said:

<?xml version="1.0"?>
<Windows>
  <MainWindow WindowMode="Fullscreen">
    <PreFullscreen IsMaximized="false">
      <ClientRect X="0" Y="0" Width="2560" Height="1440" />
    </PreFullscreen>
    <DeviceMode Width="2560" Height="1440" RefreshRateNumerator="0" RefreshRateDenominator="0" />
  </MainWindow>
</Windows>

width and height set to exact screen and game resolution. X and Y set to 0.

then i set the file to read-only. now it works every time for me. the game itself tries to mess it up every time and now can't.

The described workaround should work, but keep in mind that it can lead into update issues if something changes ;).

A better way is to simply delete the windows.xml file under: Documents/My Game/Crossout/

A new file will be generated on the next game start.


Greetz
HornOchse
  

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.