Sign in to follow this  
HornOchse

How to: fix screen out of display issues

Recommended Posts

Hello survivors,

what you can do if you run into this issue (your game screen is out of Display) :

screen-out-of-display.thumb.png.6fc510c9

This behavior can happen under the following circumstances:

1. when you change the focus of your mouse during gamestart (the Windows window management switches to scaled windows)
2. when you are using more then 1 Display (yes it happens sometimes, when Windows looses the saved position of the last state)

How to Fix: You can't fix it at this time, just because it is a standard Windows OS behavior.

But you can try not to click anywhere else during gamestart (just to prevent loosing or changing the focus). 

case1&2: Simply start your game again, and do not click somewhere else during gamestart. This should automatically fix it.

If this is not working for you, try to delete the "Windows.xml" in your userprofile at "Documents/My Game/Crossout/".
A new file will be created during your next gamesession.

Also make sure you have the correct Settings under "Main Menu->Settings->Video"

Single Display:
single-display.jpg.6f4edb4f2dbf1394751bb

More then 1 Display:
more-displays.jpg

 

If this also isn't working for you, you can try the Workaround as follows (not recommended).

Workaround:

You can find a config file "Windows.xml" in your userprofile at "Documents/My Game/Crossout/"

Single Display:

<?xml version="1.0"?>
<Windows>
  <MainWindow WindowMode="Fullscreen">
    <PreFullscreen IsMaximized="false">
      <ClientRect X="0" Y="0" Width="2560" Height="1440" />
    </PreFullscreen>
    <DeviceMode Width="2560" Height="1440" RefreshRateNumerator="0" RefreshRateDenominator="0" />
  </MainWindow>
</Windows>

More then 1 Display:

<?xml version="1.0"?>
<Windows>
  <MainWindow WindowMode="BorderlessFullscreen">
    <PreFullscreen IsMaximized="false">
      <ClientRect X="0" Y="0" Width="2560" Height="1440" />
    </PreFullscreen>
  </MainWindow>
</Windows>

- Width and height should fit your screen and game resolution
- set X and Y to 0
- set the file permissions to read-only 

The described workaround should work, but keep in mind that it can lead into update issues if something changes ;).

A better way is to simply delete the "windows.xml" file under: "Documents/My Game/Crossout/" as described above.

If none of the above solves your Problem, please create a complete bug report by following this guide: How to submit a bug report

Greetz
HornOchse

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.