Jump to content

Recent issue with tracks? Movement feels very jerky/laggy


Aveneo
 Share

Recommended Posts

For a couple of days now my Armored Tracks don't behave as they should and playing in raids feels very laggy and jerky. Did something happen with tracks?

Everything was fine a while ago and I had great fun with my build but now it's practically impossible to play due to the wierd movement issues.

Did something happen during the last patch or something? I believe I started noticing these issues as soon as the new "Syndicate" season started.

If you want to test what's wrong I have a variant of the build I was using up on the Exhibition called "9k Prometheus" although I don't think it's a problem with the build but rather an issue with MP and track builds as I also noticed other players with track-builds also moving very laggy/jerky and bumping into everything during raids.

I sincerely hope this is not "as intended" or anything and that this unwanted behaviour will be fixed soon as it is just not fun playing with tracks at present time. :sad:

Link to comment
Share on other sites

  • Developer
On 2/15/2021 at 9:17 PM, Aveneo said:

For a couple of days now my Armored Tracks don't behave as they should and playing in raids feels very laggy and jerky. Did something happen with tracks?

Hello,

We are aware this issue.

Thank You for report.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...