Easy Anti Cheat

yesterday EAC started complaining about a windows dll file. Hasn’t happened before, never had any problem with either Crossout or War Thunder. Yesterday, coremessaging.dll was suddenly untrustworthy. No windows updates due, repair on the crossout launcher did nothing. Turning off EAC on War Thunder allowed it to work just fine, but that can’t be done on Crossout. Meanwhile Crossout launcher either results in that “untrusted” error or it loads EAC and the game client but never shows the game client.

A quick google led to some instructions from Gaijin for repairing EAC, but naturally they don’t work: Run EAC setup as admin, select Crossout from the list… OK so is Crossout Game 260, or Game 36, or Game 45?? Kinda hard to tell.

Chances are that some windows update or something has broken EAC, or an EAC update has broken it. Meanwhile I can’t play Crossout and my premium account sits around being wasted. Not happy. Ticket sent to Gaijin, but who knows what if anything THAT will achieve.

I get that anti-cheat is something we probably need. But if it prevents the game from loading, that’s unhelpful to say the least. I’d rather be able to play and take my chances with cheaters…

1 Like

When I used to play the original ghost reacon I decided to test out some hacks for a day or two. I actually didn’t play as well with cheats on. I guess I just wasn’t used to using them. Seeing people through wlls was messing me up and I didn’t have the AA cheat. I only tried them in regular PvP, not clan wars or any 1v1 ladder. I wasn’t about to sully my top10/top20 rankings with cheats.


This happened to me, I had to contact Gaijin and they managed to fix the problem quickly after talking to me. hopefully the same happens to you, but mine happen right after they started using the anti-cheat system

Here we go again, EAC today says shell32.dll is untrustworthy. Tried repair in the launcher but that did squat just like last time.

SO again I can’t play and my premium account time is wasted.

Did you report this to them?

Putting it here in the forum is not going to help.

I recently had the same problem the anticheat wouldn’t start because of windows trust certificates(something like that) , I tried al lot of different solutions even a windows reinstall that keep files, that didn’t work.

A full windows reinstall with a disk cleaning finally worked. I however had a problem with finding the correct security code in my email. So I clicked on Gaijin pass I reluctantly started the double authentication, then I found the right security code in a different part of my email. but since I already started the 2x authentication it wont allow me to simply use the security code, and I really don’t want the hassle that is Gaijin pass so I’m waiting on a gaijin pass work around