Frontal Shotguns Broken By Aiming Change

The change in aiming in the latest update which requires line of sight from the weapon to the crosshair in order to fire has broken the ability to use frontal shotguns (gremlins and goblins) at point blank range. These guns are designed for point blank use, with increased melee damage on impact and even a damage bonus on the gremlins based on impact force. You cannot shoot at an enemy in physical contact with these guns since the update because you do not have line of sight to the part the guns are contacting, thus blocking the ability to fire.

There is an additional problem if these weapons are aligned side-by-side, since even if you can get your crosshair on the targeted part, they cannot traverse enough for more than 2 guns to hit the crosshair location at point blank range, resulting in the outer guns no longer firing when in contact with the target.

The aiming change makes sense for most other weapon types, but it renders these weapons almost useless at what is clearly intended to be their optimal range: point blank.


Have you changed your controller settings back to the old settings?

I was finding strange why my gremlins were acting today, they always work so nice, but today, or they don’t shoot or only two or three shoot the others don’t.

I don’t have a controller, i play on PC.
But it’s not just that, graphic wise… i don’t know. The best way i can describe it
It’s like i’m been playing C.O.D. and now i’m playing B.I.A. inferior gameplay and clunkier graphics.
I haven’t had motion sickness or anything like that.
But the sound effects (explosions) are rubbish, with all the unnecessary fire and smoke i can’t make out if it’s me burning or the wreck of the other build, i can’t see where i’m going after i punched through the first build missing to facehug the next build.
Can i go back?

I play on PC, not with a controller. It’s not a settings thing, it’s how aiming has been changed. I don’t mean on sideways capable movement parts. They also changed where your aim point is taken from so that it’s easier to aim at stuff on the top of builds now, but that breaks aiming at anything which you cannot directly place your crosshair on. Intervening parts become the target and if your guns can’t traverse to face your crosshair they won’t fire.

Actually I think the fundamental change is that you used to be able to fire even using a limited turn angle gun which didn’t have line of sight to the target, as long as the line of sight wasn’t blocked by your own parts. Now you can only fire if your gun can aim at your crosshairs in your current vehicle position (even if it’s not currently aimed at it).

1 Like

Bumping this because it needs to get fixed. This also affects Dracos.

1 Like

You do know that the dev team has not been to or read these forums in like 9 months right?

Make a bug report is the only way it will get to them.

Only community managers read the forum and Reddit. A developer will never see this.

Just a heads up.

Thanks, I was not aware of that. I’ve put in a bug report.


Also you can use the “Game suggestion” button on top of the forums for a second way to message them.

I’m confused by this part. If I remember correctly, you used to be able to aim to the side beyond the capability of the gun, and shoot forward. And now you have to actually aim at your target?

I can see that being hard to adjust to, but there is a certain logic to forcing you to actually aim at your target.

If I am misunderstanding, apologies.

On PC you can lock your gun position. Console we can not.

I wonder if that is it?

Actually, with the new update we can lock our guns too (at least on strafing parts).
I’m not sure if free look works on non-strafing parts, but it probably does.
It’s the left joystick button on PS4. The right joystick is like a rear view mirror.

1 Like

Well then maybe because they added that they expect people to lock the guns?

Not sure :slight_smile: just trouble shooting.

It might fix his issue.

I’m going to have to look into that feature.

1 Like

Hmmm just tried, not sure it works like that.

Maybe I’m doing something wrong, but I can’t lock my guns movement.

Are you holding it down? And are you on a strafing build?
If you look in the controller settings there’s a screen displaying how the controls are assigned.

The free look button and the reverse button are pretty useful on strafing builds. There are also settings for inverting controls when using the rear view, which is great when you need to make a fast retreat.

The issue isn’t really one of having to aim at the target, it’s that you simply can’t get all of your guns to fire at point blank if you’re running more than a couple gremlins or goblins. If you aim at an upper area on the enemy build the guns can’t traverse up enough to hit it. Previously this wasn’t a huge issue because they’d still fire, allowing you to hit as high as they could aim on the enemy build.

Now, if you try to aim low enough on the enemy build to allow your guns to fire, and you’ve got your guns planted right in their side (which is often the case with goblins/gremlins) only 1 or 2 guns will actually fire if you can even get your crosshair on a part low enough to allow them to fire. This is because the guns mounted further from the center can’t rotate inwards far enough to get line of sight to your crosshair location. If you’ve shoved your guns under their cabin and are trying to shoot out their generator (a primary tactic with goblins/gremlins) they can’t fire at all because your crosshairs are on their cabin and the guns can’t aim upwards that much.

I just confirmed that holding ALT with the guns aimed in an appropriate direction does still allow them to fire even if you’ve stuck them under an enemy build, but this is both awkward and less effective than how they used to work. I can’t imagine this was an intentional change given the fact that you’re intended to ram these guns into enemy builds.

1 Like

Oh man, that is definitely not good.
Have you filed a bug report?

I was not on a strafing build. I want it to work for fire bugs :slight_smile:

PC weapon lock is one button push and locks any gun in the position your aiming with one click and unlocks with a second click.

Not really the same.

1 Like

I have filed a bug report, we’ll see if it makes any difference. I also noted that this change impacts Draco flamethowers as well.


It’s not the aiming, it’s the free look

if you press ALT in simultaneous with any movement key, the Gremlins will work as before, as long you keep pressing the ALT key all the time.

1 Like

I tested it last night on a wheeled build, and free look works on them too. You just have to hold it down. Unfortunately, it seems to disable steering while you do that, and disables strafing on those builds. Hoping that is a glitch that will be fixed.