Steering glitch

Has anyone else noticed a weird steering glitch over the past few months?
I first noticed it when the claw wheels came out, and thought it was just them, but I’ve been noticing it happening on other builds too.

On some builds, when I start skidding in a turn, the steering seems to get locked into that turn until I slow down significantly, or until I turn in the opposite direction.
If I stop turning and keep the gas going, it will keep driving in a circle indefinitely. The ST wheels aren’t turning onscreen, but the car is.

Seems to happen mostly when combining different types of wheels, and when putting ST wheels on the rear and front, with at least two non-ST in front. Speed and spacing of wheels also seem to be factors.

It’s like the drifting algorithm gets overloaded and stuck in certain scenarios.

I’m on PS4, in case it’s a platform specific glitch.

Anyone else seeing this?

Yes it is an issue and its not just you but according to xo devs its your internet which is a complete load of bs.

Every season gets more buggy as they refuse to go back and fix up their net code because its easier to blame something else

Its along the same lines as the tether bug that you might have also have seen where you can’t drive move than one meter out of the starting zone before getting pulled back

I would be great if they would fix that and the tonnage bug but its never gonna happen so just drop out of those matches and requeue as its the only fix

I can believe that lag might have something to do with it, as sometimes I’ll test a build in the range and it handles normal, and then in matches or raids it’s fishtail city.
However, I can duplicate it on the range with some builds, so it can’t just be lag. If I can do it deliberately and predictably, how can it be internet issues?

1 Like

I always assume it was/is lag from their old/not well-maintained servers, from how you describe it, it sounds like lag more than a glitch!

Nope it happens to me and I’m PC and seen this issue with Xbox players too.

Yup, it’s always on our side, sounds like excuses people who only want to find ways to get the $$$ rather than
to regular and proper maintenance on their game cause that doesn’t rake in the $$$$

That only helps me about 5% of the time
Though lately this bug/lag comes and goes, while for like almost 2 months it was 100% of all pvp/pve matches
I also get bad lag when a player gets loaded into a raid after it’s already started for me

It’s probably a combination of a bug and lag, but remember the devs said it’s on our side, the same person who say’s that got their dev image as a portrait in game haha

The other reason I don’t think it’s just lag is that I can fix it by using all of the same wheel type, or by moving my wheels around in some
cases. It seems specifically triggered by drifting.


thx for the info :stuck_out_tongue_winking_eye: we need more trouble shooters…thx

1 Like

I don’t think I’ve had this and I only use wheels really, st in front, non st in back, odd

That’s how I usually build too, and I don’t experience it with that setup. Which makes me wonder if it’s been happening for longer than I’ve noticed.
Only on six wheel builds, with non-ST in the middle, and a mixture of wheel types.
Four wheel builds behave normally.

Tried with multiple wheel types, 1 2 and 3 types, can’t seem to replicate, might have weight/wheelbase width differences too, plus speed… might be hard to replicate, also I know the garage doesn’t perform the same as laggy pvp/pve servers

also mien were 4 frame wide, and the back 4 closer together than the front wheels

1 Like

I discovered today that I can make the glitch happen even when running six of the same wheel type. Was testing an unarmoured sketch of a build, and started getting stuck in a turn whenever I got close to 100kmh.

Tried rearranging my wheels, and eventually eliminated it:

Definitely seems to have something to do with the drifting mechanism, as the fixed build doesn’t corner as sharply or skid as easily.

thanks twitter